DOM javítás DOM csere

Sziasztok,

Egy tanulságos megoldást szeretnék ismertetni, amire remélem sosem lesz szükség, de ha mégis akkor pedig vélhetően ad tippeket a megoldáshoz. Próbáltam feltölteni PDFben de nem sikerült, akkor íme a teljes szöveg:

Hibás DOM javítása. (QNAP NAS)

Tartalom jegyzék.

  1. Mi a DOM
    1.2 NAS típusa
    1.3 Tényleg halott e a DOM?
    1.4 Mi a hibajelenség?

  2. Hivatalos megoldási javaslatok
    2.2 Hibás egység pótlása

  3. A bevált megoldás

  4. Alternatívák

  5. Néhány szóban erről a típusról

  6. Mi okozhatta ezt az egészet?

A DOM egy Disk On Module egység ami jelen esetben egy alaplai USB- csatlakozóra dugott „pendrive” perszer a megfelelő (alaplapi) csatlakozóval ellátva.
Mivel a gyártóval folytatott levelezésből kiderült, hogy ilyen egység külön nem kapható, ezért alternatív megoldást / megoldásokat kellett keresni.

1.2
A szóban forgó NAS egy Qnap HS-251+ ennek jó és rossz tulajdonságairól az 5. pontban. A megoldás azonban minden típusra jó lehet.

1.3.
Nem egyértelmű, hogy amikor a NAS nem indul, mi is a rossz. Elsőre mindenki másra gondol, az biztos, hogy ha a vinyóknak bármilyen baja van, a NAS rendszerének fel kell tudni alap szinten állni, és a NAS valamilyen módon elérhető kell maradjon, és ez után lehet konstatálni, hogy melyik lemez lehet a hibás.

Amikor a NAS semmilyen módon nem elérhető ( kivett lemezekkel sem) és a működését jelző fény elakad kialszik, és a semmilyen programmal nem tudjuk elérni, akkor gyanakodhatunk valami más, komolyabb dologra.

Mindenhol azt írják, hogy NE vegyük ki a lemezeket, de ez pusztán elővigyázatosság, én javaslom kivenni, hiszen az esetemben közel 40 év fényképei és családi eseményei vannak összegyűjtve rajtuk, és véletlenül sem szerettem volna tényleges lemez sérülést. Kivételkor egy alkoholos filccel ráírtam melyik tálcában melyik lemez volt és így már nem lehet őket felcserélni.

1.4
Tehát a hiba jelenség:

Bekapcsoláskor a NAS egy hosszút csipogott, majd a „szokásos „ indulásnak tűnő várakozás után a gép hátulján elaludt a hálókártya működését jelző mindkét led, majd végtelen várakozás kezdődött.
Mindössze a bekapcsolást jelző LED világított.
Szétszedett állapotban a DOMon lévő kis led néha fel felvillant, majd kb. 10 perc után más semmi, és ez így ment kikapcsolásig. Bekapcsoláskor a DOMon lévő leden látszott a töltés folyamata majd ismét kialudt és utána semmi, ez a folyamat, a villogás és látszólagos töltés nagyjából 10 perc utána órákon át semmi.

Ez a modell rendelkezik HDMI kimenettel ezért Tv-re kötve látható a bootlás folyamata. Megnézhető a BIOS és ellenőrizhető, hogy a BIOS-ban látszik e a DOM. Ez jelen esetben IGEN.
Tehát látszólag jónak tűnik.

Ez után a képernyőn két egymásba forduló kocka látható. Itt akad meg a folyamat, tehát a bootolás innen nem megy tovább a hálókártya elalszik a NAS tetszhalott.

A hivatalos megoldások a DOMon lévő rendszer újratelepítését javasolják. Nagyon jól összeszedett wikipeida cikk:

Külföldi forumon innen indul a téma:

Érdemes ezzel kezdeni, de jelene esetben ott akadt el a dolog, hogy a javasolt renderek nem látták a NASban lévő DOM modult, azaz bármiféle helyreállítási hivatalos kísérlet ott hasalt el, hogy nem volt CÉL meghajtó, amire fel lehetett volna tölteni a gyári lemezképet.

Innen indult a fejvakarás, és ez döntötte el, hogy halott az egység.

2.2
Mivel már „biztosan” eldöntöttük, hogy meghalt a DOM felmerül a nagy kérdés, hogy honnan lehet pótolni az esetemben 512 MB-os Apacer modult.
A gyártó válasza, hogy külön egységet nem árul, új nas kell. Ez a válasz számomra nem volt túl baráti, ezért némi kutakodás után találtam használt „gyári” és sokkal több kutakodás után új, nem gyári modulokat. Ez utóbbinál maradva jó néhány kereskedővel felvett kapcsolat után kiderült, hogy ezt az egységet nem olyan egyszerű beszerezni, mivel a legtöbb helyen már csak kint felejtett hirdetést találtam. Pár hét után egy kereskedő visszajelzett hogy olyan modul nincs már, de egy 8 Gigás példányt szívesen elküld. Belementem és vártam a postát, egy hónap alatt meg is érkezett.

Ez alatt az egy hónap alatt ami végül majdnem kettő lett, volt időm próbálkozni.
Bármilyen gyártó által javasolt rendszer ISO-val indítottam el a NASt az egy bizonyos ponton elakadt így szinte biztos voltam már benne hogy a DOM miatt van ez, hiszen bár látja, hogy ott kellene lenni valami meghajtónak, de mivel nem tudja olvasni, egy végtelen próbálkozásban hal meg az egész. Egy fura ötlettől vezérelve kivettem a DOMot és a rendszer felállt, hibajavító módba lépett a leírtaknak megfelelően de mivel nem volt bent a lemez, nem volt célállomás a javításra.
Itt kellett volna az új egység.
Poénból közben kipróbáltam a NASt Ubuntuval, és más Linux verziókkal, tulajdonképpen egy elegáns PC-t kaptam egy nagy tv-re kötve. Teljesen jól használható volt netezni és filmet nézni.

Mivel a DOMnak már „minden mindegy „ alapon úgy is vége volt, ezért egy szétvágott egér kábele és egy alaplapi USB „lógató” (hátsó kivezetés) házasságából előállított kábellel rádugtam egy Wines gépre.
Az rögtön meglátta, de hibás „olvashatatlan” partíciónak ítélte. Persze, hiszen Linux fájlrendszert nem olvassa a Windows alapból. Ehhez vannak mindenféle kis programok, ezekkel megnézve valamiféle könyvtár foszlányok látszottak.
Mivel elkönyveltem a DOM-ot halottnak, ezért bátran mondtam a Winnek hogy akkor partíciókat le és nézzük mi lesz. Ez nem sikerült, a win nem tudott mit kezdeni a lemezzel, ehhez külső partíció kezelő programot kellett segítségül hívni. A végén sikerült kapnom egy tök üres 512 MB-os meghajtót. Pár tesztet futtatva mind az írás mind az olvasás rendben volt és a lemez felület ellenőrzés sem talált hibát.

Itt elbizonytalanodtam, hogy akkor vajon tényleg halott e a szóban forgó DOM.

Ezért ment is vissza a NASba, de a gyári megoldás által javasolt program ugyan azon a ponton halt el.
Ekkor fogtam és elkezdtem a lemezképet Win alatt kiírogatni a DOMra, ezek közül semmi nem készített indításra alkalmas megoldást. ( Unetboot, Rufus, Winima… stb…) Ekkor jött az ötlet, hogy az Ubuntu saját diszk image írójával próbáljuk meg, hátha, hiszen az Ubuntu sikeresen felbootolt a NASon ( szemben a gyártó által javasolt szintén Linux alapú megoldással aminek mindössze egyszer sikerült indulást produkálni, és akkor sem látta a DOMot)

Ez össze is jött, a lemezkép rákerült az immár leformázott és Ubuntu alatt is elérhetővé vált DOMra.

Ez után a NAS elindult! Bár az első indulás kicsit hosszabb, de az már biztató jel volt, hogy a háló kártyán a ledek folyamatos villogása nem állt le és a Qfinder is megtalálta az eszközt.
Persze egy 10 évvel korábbi rendszerrel de látszott, hogy valami történt.

Ez után jó pár frissítés következett, érdemes utánanézni melyik verziónak mi az alap admin jelszava! Ez a gyártó oldalán elég jól dokumentált! De pár kellemetlen pillanat elkerülhető az ember felkészültebb… ugye a saját felhasználónk a kivett vinyókon pihen…

Amikor az utolsó frissítés is felkerült a lemezeket egy nagy levegő kíséretében vissza tettem és lám lám a NAS elindult és minden elérhetővé vált.
Egy működést nem befolyásoló de bosszantó probléma volt, hogy a Qfinder jelezte, hogy a DOM és a HDDken lévő rendszer nem egyezik, frissíteni kell. Ezt ugyan megcsináltam több alkalommal de a hiba nem múlt el.

Amikor már minden jónak tűnt és a NAS a szokott módon elérhetővé vált akkor a webes felületen elkövezett második frissítés után szinkronba került a Qfinder és a belső program által látott verzió.

Közben megérkezett a rendelt egység. 8 Giga és teljesen jónak tűnő, ám első használat alkalmával ezt is particionálni és formázni kellett.

Amíg a DOMra vártam több más megoldást találtam, a legegyszerűbb az lett volna, amikor egy alaplapi USB lógatót egyszerűen rádugtam a nas alapjára és abba egy pendriveot dugtam. Jó és működő megoldás lett volna, ingyen, de szét kellett volna faragnom pár dolgot, amit semmi módon nem szerettem volna, de a tény, hogy a NAS alaplapján egy sima USB csati van erre módot ad.
A másik megoldás egy törött csatlakozós 16G-s pendrive átforrasztása lett volna, feleslegesen nagynak ítéltem és jó lesz az még másra. Az ötleteket más már megcsinálta:
…a harmadik hivatkozást a rendszer nem engedte.:smiley:

HS-251+
Egy nagyon jó ötlet megvalósítása, miszerint legyen a nappali éke a NAS és mivel a DVD és VHS lejátszók jó része elkerült a TV közeléből, ez az egység egy dizájnos és hasznos kiegészítő lehet.
Ez így is van, a NAS jó, otthonra több mint elég, komolyabb felhasználásra viszont már kevés.
Média lejátszónak sok, mint nas roppant összetett és nagy tudású, de tudása jó részét bekorlátozza a 2G memória.
Szóval egy félmegoldás, valamire. Viszont lapos, kicsi, „halk” hiszen passzív hűtéssel bír. Így szétszedett állapotban számomra érthetetlen volt, hogy a lemezek miért fejjel lefelé vannak benne, a lehető legrosszabb módon van benne elhelyezve hőleadás szempontjából. A rendszer processzor és minden más fejjel lefelé így a felszálló hő egyenesen a nyákra kerül, ahelyett, hogy az amúgy elég vastag tetőlemezt vinné el a hő nagy részét. A lemezeknél dettó az elektronika van felül így a HDDk által termelt hőt a saját elektronikája kapja, ahelyett, hogy a lemez felső, fém felülete felé távozna. Ezt nem egészen értem, az egész NAS hűtés szempontjából fejjel lefelé van… Nyáron kifejezetten kellemetlen meleg tud lenni. Ettől függetlenül nagyon jó eszköz, a nappaliban a Tv alatt teljesen jól látja el a feladatát, most, hogy ismét működik.

Próbálom kitalálni az okokat, hogy hogy sérülhetett meg a DOM. A sérülés alatt azt értem, hogy bár a lemez mint kiderült fizikailag jó volt, de a rajta lévő rendszer (több partíció) bizonyos részei elhaltak és ez okozta az indulásképtelenséget.
Mindenhol azt olvasni, hogy megszakított frissítés, áramszünet stb. Ezeket kizárnám, mivel 40 év „adatai” vannak rajta, ezért kifejezetten igyekszem minden ilyenre odafigyelni és egy szünetmentes is ketyeg az eszköz alatt, így mind a hibás frissítés mind az áramszünet biztosan kizártnak mondható.
Ellenben pár hónapja felfigyeltem egy jelenségre, hogy a NAS sosem kapcsol ki, annak ellenére, hogy be van állítva az alvó mód. Ez mondjuk részben igaz, hiszen a beállított idő eltelte után leállt a NAS ellenben ahogy a lemezek leálltak, már pörögtek is fel, ez legalább plusz pár ezer felrpörgést jelentett hetente. Amikor próbáltam kideríteni az okokat, szintén gyártói fórumon az olvastam, hogy a cronban található dolgok időzítéseit is érdemes megnézni. Persze ilyenek, hogy torrent lekapcsolás és egyéb alap ötletek után.
A chronban figyelmes lettem néhány, szerintem oda nem illő dologra, ám ezeket törölve sem oldódott meg az alvó állapot kérdése. Amikor pedig az egységet kikapcsoltam, bekapcsolás után a cronba ismét visszakerültek az általam törölt bejegyzések.
Akkor a szupport véleménye az volt, hogy nem kell aggódni azok kellenek oda, és biztos valami más ébreszti fel a NASt, mondjuk egy wines gép tallózója. Hajnal háromkor ez nem jellemző annyira, és még az okos TV sem akart éppen semmit. Nekem végig a cronban lévő gyanús bejegyzések voltak a legfőbb gyanúsítottak.
Volt egyenesen olyan hozzáállás is ami azt firtatta, hogy ez egy NAS aminek 0-24/7 ben működni kell, minek akarja valaki egyáltalán alvó módba küldeni. Oké… ezzel nem vitatkozunk.

Mindezek után megoldás hiányában túrva a netet belebotlottam pár cikkbe amik Qnap NASok fertőzöttségéről írtak, és furcsa módon ezek cikkek olvasása után nem sokkal, egy következő frissítéssel települt a rendszerre a Malware Remowal tool.

Aztán ez dolgozott egy ideig, és talán jelezte is hogy volt valami de megoldotta, a cronból tűntek el számomra nem oda illő dolgok, de az alvó mód kérdése, csak félig oldódott meg, bár a helyzet javult, már hosszabb ideig pihent a nas, így főleg nyáron, hűlni is jobban tudott.
Majd mindezek után jött a pillanat, ami a fenti esetet generálta. Véleményem szerint tehát valami bent ragadt és félsikeresen eltávolított kártevő lehetett az okozója a DOMon lévő rendszer lehalásának. Ez persze csak egy tipp. De jobb ötlet híján ez maradt meg. Felmerül persze a kérdés, hogy fertőződhetett meg a NAS, hiszen csak a gyári letöltő helyről kerülhetett rá bármi is, a jelszavak amik amúgy is elég jónak mondhatók voltak még durvábbra lettek cserélve és persze az admin fiók sosem volt használva… sem semmihez engedélyezve.

A lényeg, hogy a HS-251+ ismét teszi a dolgát. Működik és van egy tartalék egységem a jövőre nézve, és remélem nem lesz rá szükség. Egy dolgot mindenkinek tudok mondani, hogy az első szívinfarktus után, miután tudatosult bennünk hogy mi történhetett le kell ülni és meg kell nyugodni.
Amíg a lemezeket nem rongáljuk meg az adataink megvannak tegyük ezeket biztos helyre, utána kezdjünk neki a feltárásnak! Mindenre van megoldás de a kapkodás nem segít de bátor kísérletezéssel sok probléma megoldható, fórumokon szinte mindenre van jobb, rosszabb megoldás.

Remélem nem lesz szüksége senkinek ezen leírásra, de ha mégis akkor rengeteg időt és energiát megspórol vele.

Vannak képek amik a javítás alatt készültek ha esetleg valakinek egy egy mozdulatról kellene kép szóljon, egyébként nem töltöm fel.

©Rónay Gábor 2020

3 kedvelés

Köszönjük! Ez egy kiváló leírás! Csak így tovább!

Köszönöm , sose legyen rá szükségetek! :smiley:

2 kedvelés

Valamiért nem tudom szerkeszteni de nem is fontos. Inkább egy kis frissítés. Nyár 40 fok szabadság stb., az ember elmegy és nem szívesen hagy otthon semmit bekapcsolva hosszabb időre.
Ki kapcsoltam én is a cuccot, áramtalanítás és jónapot. Hazaérve, kapcsolom be a Nast, semmi…
A fenti hibajelenség annyival talán másabban, hogy az első beep után úgy alszik el a hálókártyán a led, mint az autókban a késleltetett belsőtér világítás. Szépen de gyorsan és mindkét led ( sárga és zöld) egyszerre alszik ki, mintha elfogyna alatta az áram… lemerül az akku…

Immár kicsit gyorsítottam a folyamaton. ubuntu bebootol az indító lemez készítő 2 perc alatt felírja a kivett DOMra a cuccot és már indul is a nas.

Azt íram fent hogy a gyártó oldalán dokumentálva van minden hát azért leírom mert ne kelljen már keresgetni.
Az alap jelszó az admin / admin páros a letölthető TELJES közel 500 Megás imageken. Az újakon admin és a MAC adr… szóval itt :

Amúgy nagy okosan miután minden működött anno, szépen gyalultam mindent, így ismét töltögetni kellett… HA egyszer valaki megcsinál valamit, tessék alaposan eltenni mindent!!

Na nézzünk hogy áll a frissítés, a beepeket már tolja ezerrel …

Egy gyanú felmerült miközben azon agyalok miért szívhatok ezzel már másodjára? Egy ötlet szinten felmerült dolgok, hogy lehet, hogy akkor kapott egy áramszünetet a cucc, amikor éppen hibernálva volt!! És ebből nem tud fel - vissza állni. Ami elég tré lenne mert minden linux megoldja, a Win is képes rá, max. köhög kicsit… de egyelőre más ötletem nincs!!
Mekkora eséllyel kétszer szívok ezzel?

Frissítés: Működik minden. Azért van valami flusztráló abban, hogy ez így mondhatni a semmiből jön elő és éppen a gyerek egy születéskori képét kellet volna (gyorsan) elküldeni róla… A meglátásom az, hogy valóban pótolhatatlan dolgokat legalább két módon és földrajzilag két helyen kell tárolni, akárháy de legalább két példányban. Kicsit rossz ezen agyalni amikor eléggé fent vannak lemez árak.

1 kedvelés

Hidd el, ezt sokan nem így látják… “Azért veszek NAS-t, mert akkor biztonságban van mindenem” állásponttal nehéz mit kezdeni, mert a legtöbb felhasználó nem érti, hogy a NAS = szerver, amihez a hétköznapibb ember is hozzá tud nyúlni. Ahogy a szerverhez, ehhez is kell tűzfal, stb. És persze kell, hogy legyen mentés.
Én picit másba futottam bele, nálam valamiért nem akart lefutni egy idő után a mentés. A vicces, hogy, mint utóbb kiderült, nem a NAS volt a hibás és nem a backup eszköz… Valamiért, hibásnak minősítette a HBS3 bizonyos fileokat. Többségében PSD-t…

Kicsit volt időm és kellő nyugodtság, hogy megint, immár szándékosan hazavágjam a vasat. Úgy tűnik sikerült. HA lemegy a nas aludni és úgy van agresszívan kikapcsolva vagy kitépjük neki a tápot akkor a következő indulás az sikertelen és a fenti jelenség áll elő. Nem mondom, hogy próbáljátok ki, de figyeljetek arra, hogy ha alszik az eszköz akkor ne rántsátok ki az áramot ha csak nem muszáj. Nem emlékszem hogy ilyeneket valaha tettem volna de ezzel elő tudom idézni a hibát. Egyelőre mással nem. Régen volt pár áramszünet azóta szünetmentesen van biztos ami biztos tehát ez elvileg nem lehetett nálam anno szándékos.

Ami viszont továbbra is nagyon zavaró az az, hogy ha lemegy NAS aludni akkor akár mi van 10 percen belül felpörögnek a lemezek. Ez nagyon nem tetsző dolog! Semmit nem futtatok minden task kilőve és felpörög ha kell ha nem. Bosszantó, hogy a három éves lemezek felpörgés száma az egekben miközben a hat éves széthajtott lemezek az éles vasakban még csak egy smartot sem dobnak, :smiley: ( orosz rulett) az itthoni lemezeim, meg olyan hangot kezdenek adni mint egy 30 éves betonkeverő.
Nem rosszból de a konkurencia cucca, az a pénteki utolsó kolléga hazamenetele után 20 perccel lekapcsol és hétfőn az első bejelentkezéskor ébred fel…
Még próbálom megfogni milyen eszköz lehet a hálózaton ami rápingelhet néha, esetleg tv vagy volumio de azok is alszanak mondjuk hajnal háromkor…

Ez a következő megfejtendő.

1 kedvelés